Top Top Nav

How to fix WordPress 3.3 Upload Media bug in Safari

This video tutorial is for you WordPress users out there who have encountered issues after updating to the latest version of WordPress  3.3 —specifically issues with uploading media into posts and pages. “Sonny”, as it is called, is quite slick, but there are issues if you don’t empty your cache after updating WordPress. I updated to the latest WordPress version and was frustrated when I couldn’t get the upload media window to work. I wanted to insert an image, and just got a black screen. I wish I had read this super helpful troubleshooting list before updating:

http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list?replies=5

The solution to the WordPress 3.3 upload / insert media bug in Safari (perhaps in other browsers too) is to simply empty your cache. All of us web designers / webmasters  using WordPress should be doing this regularly—regardless of which browser we use—but it’s especially important if you’re using Safari on the Mac, as I recently discovered. I created this tutorial is for you mac folk out there.

Feel free to watch the whole video, which demonstrates adding an image into a page before and after the WordPress update. I showcase what happens to the add media window after updating to 3.3, but you can jump ahead if you wish to 4:30 min:sec to see the empty cache solution. Hopefully you watch this before updating to 3.3 to prevent any frustration in the first place.

Happy blogging.

, , ,

5 Responses to How to fix WordPress 3.3 Upload Media bug in Safari

  1. Susan Ackerman December 16, 2011 at 8:47 pm #

    What a good educational idea!!
    I do not need the information myself, but I am sure that those who do, would find your explanation very clear and useful.

    • admin December 16, 2011 at 11:50 pm #

      Glad you approve! It’s an important little tip that saves a lot of headache, so I felt compelled to share it with others. Cheers!

  2. Glendyn December 28, 2011 at 6:09 pm #

    Hi Chris,

    I found your YouTube video about fixing the image uploader in WordPress 3.3 as I was having no luck trying other things.

    I followed your tips and it fixed the problem.

    Thanks!

    • admin December 28, 2011 at 7:43 pm #

      Hi Glendyn:

      I’m glad that it helped. Thanks for the comment!
      Cheers to you,
      Chris

  3. admin December 20, 2011 at 9:58 am #

    Hi Yuri

    Have you tried any of the other troubleshooting tips listed on the WordPress support page? With your particular theme, you might have to try deactivating your plugins to isolate a problem.
    Here’s the link again:
    http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list?replies=5

    Thanks for the comment, let me know how it goes.
    Cheers, Chris

Leave a Reply

Powered by Wordpress, designed by Chris Gooderham & Woothemes